To link a Gate.io exchange account you need to use keys for the proper version, APIv4. Support for APIv2 keys will end on November 16, 2021.

Log in to your Gate.io account. In the settings menu find the API Management page.

From the management page, select 'APIv4 Keys' from the left side menu, then click the '+Create new API Key' button on the right side of the page.

In the Remark field, give the API Key a name. In the example we use 'CoinTracker,' a good name to use so you will remember why this API key was created.

Enable all permissions, and set them all to 'Read Only' -- this means CoinTracker can see your complete history, but cannot execute trades or withdrawals on your behalf. Because your keys are read-only, even if someone gained unauthorized access to them, your funds cannot be withdrawn.

Leave the IP Whitelist empty, then click Confirm & Create

You will be prompted to enter your trading password and authenticate. Finally, you will need to copy the API Key and API Secret and paste them into the appropriate fields on the Add a Gate.io Wallet page on CointTracker.

If you previously had a Gate.io APIv2 account, you will need to remove it from CoinTracker. First verify your new APIv4 account is added correctly and syncing. Then head to your original Gate.io wallet on the Wallets page and select 'Remove Exchange' from the dropdown menu on the right side of the screen.

Having problems making this migration? Don't hesitate to reach out to our support team.

Did this answer your question?